Problema con Citrix Secure Gateway y Ubuntu 10.10 64bits

Hola a [email protected]

Los cambios son grandes y el tiempo material es pequeño para poder dedicarlo a mi blog.

Aún asi, intento hacer alguna que otra colaboración…

Aqui vá una de ellas, os comento mi problema…

Tengo una máquina con un Ubunut 10.10 64bits que es mi estación de trabajo, tengo instalado Firefox versión 3.6.24 y Google Chrome con la versión 14.0.835.186, tambien tengo instalado el Citrix Receiver con la versión 11.100.158406 bajado desde la página web de Citrix.com

Ya sé que es un error antiguo, pero vamos… poco a poco…

El error que me he encontrado desde hace algún tiempo ya, pero que no he tenido mucho tiempo para resolverlo, fue el siguiente…

Al acceder a XenApp (Citrix Secure Gateway) de mi empresa para labores de gestión remota al intentar ejecutar el fichero launch.ica con el Citrix Receiver me sale el siguiente error:

 

 

La causa es relativamente sencilla, como parece ser que la aplicación de Citrix no trae los mismos certificados de entidades certificadoras que los navegadores web, al intentar validar la comunicación no lo reconce y genera el problema de confianza.

¿La solución? tambien es sencilla, lo que necesitamos hacer es exportar el certificado publico de la entidad certificadora y copiarlo en la carpeta correspondiente del Citrix Receiver.

Empezamos poco a poco y primero exportamos el certificado:

1- Accedemos a las propiedades de Mozilla Firefox y en la administración de certificados digitales exportamos el siguiente certificado:

Exportamos con la siguiente opción:

 

Ahora el siguiente paso es copiar el fichero que hemos exportado al siguiente path:

/usr/lib/ICAClient/keystore/cacerts/

 

Ahora en el momento en que arranquemos nuevamente el cliente Citrix Receiver ya deberia funcionar correctamente.

Espero que os sea de utilidad.

 

Gracias por leer mi blog.

Un saludo a [email protected]

Vulnerabilidad detectada en Asterisk – (DoS)

Desde el blog de hispasec me encuentro con un documento tecnico que describe una vulnerabilidad detectada en la plataforma de telefonia IP por excelencia Asterisk.

En el documento explica de una manera bastante interesante y principalmente con una prueba de concepto la vulnerabilidad.

Aqui os dejo un enlace a la pagina de hispasec, donde se puede ver en “Noticias Corporativas” el documento tecnico y aqui os dejo un enlace al documento tecnico.

Por si alguien lo quiere en English, aqui dejo el enlace

¿Solucion para la vulnerabilida? como siempre la actualización es tu mejor opción….

Un saludo a [email protected] y gracias por leer mi blog.

Otra de Linux X Windows

Navegando como siempre…

Me encuentro con la noticia que el gobierno de India ha decidido cambiar el 99% de sus sitemas Windows a soluciones OpenSource (LINUX).

Segun C. Umashankar, director ejecutivo del proyecto de migración de sistemas, Linux está libre de virus, posee actualizaciones constantes, es muchissimo más barato que Windows.

Bueno… un país más que decide cambiar, mejor dicho, introducir OpenSource en sus “dominios” excluyendo la todo poderosa Microsoft.

Fuente: www.faq-maq.com

The New York Times… Contra Windows….

Ahora mismo he encontrado este link que dice que el periodico The New York Time no recomenda el uso de Microsoft Windows como sistema operativo debido a sus problemas de seguridad.

Muy interesante como ese articulo publicado en Baquía y haciendo referencia al articulo en The New Yort Time se puede considerar un avanzo en el cambio de mentalidad en los usuarios y principalmente en la gente que hace “recomendaciones”, poniendo de manifesto que realmente existen fallos y que hay alternativas en el mercado de los S.O.

Saludos.

Puñeteras actualizaciones de software…

De verdad… es que estoy hasta el moño de las actualizaciones de software….

Os explico mi problema….estoy trabajando en la actualización de un servidor donde tenemos instalada una plataforma de enseñaza a distancia (moodle) y tengo una cantidad de problemas a la hora de exportar e importar las bases de datos de servidor “antiguo” para el nuevo….

Vale… la versión de MySQL y PHP es un “pelín” distinta, pero jobar…. no me carga correctamente las bases de datos… y encima el puñetero programa mysql-admin (GUI para administración) a la hora de trabajar con los usuarios me cuelga… es que todo eso me pone de los nervios y me sobrepasa…

Podeis decir: “bueno tio… entra en modo mysql> y trabaja como un campeón”… 🙁 es la ost.. quiero que las importaciones y exportaciones, configuración de usuarios, privilegios, etc… se haga rápido y sin la necesidad de usar la consola… no tengo mucha memoria (una ampliación em vendría muy bien…) para acordarme de todos los comando de mysql…

Toy hasta los wuebos….. me voy a comprar un par de cabras y me piro al monte a vivir del queso… y de vino.. por supuesto

😉

Bueno… ahora mismo me piro de Valladolid y cuando llegue a León volveré a calmarme y seguiré trabajando en ello….

Eso es sólo para desahogarme….

Pu.. sistema de mie… :@